Speeding up switching from one mode to another.

Chuckmet

EOS M50
Jan 18, 2019
25
16
I have been experimenting using my M5 with my longer lenses for bird photography and it works pretty well with one exception. When I switch from C1 to C2 there is a lag when the top row of icons show up to display the new mode before being applied. I use my C1 setup for primarily shooting stationary birds and my C2 setup for birds in flight, however I quite often have to switch quickly in order to catch the birds in flight and this lag means more missed opportunities. Yes, I do have the "tips" turned off in the menu. Has anyone else experienced this and figured out any way around it?
 

dppaskewitz

EOS 80D
Jul 19, 2011
181
3
72
I have noticed the same thing when switching between modes on my M5. I have C1 set up for "snapshots" (when I want to snap something in a hurry or hand the camera to someone else to shoot) and C2 for my normal Manual mode shooting (again, a "go to" if I am coming out of some random setting and want to throw it on the tripod, have it ready to fire with the remote and catch the light or something like that). In neither case do I need to be reminded that I just switched Modes. I know I did. I had to depress the little detente (or whatever its called) on the mode dial. Hard to do now by accident. (And while I'm bitching, why does it have to reset from remote firing whenever it's turned off. A waste of time). Both the Mode thing and the "turn off the remote" thing lead to missed shots and are totally unnecessary. ---End of Venting--- And, in answer to your question, I just went through all of the menu items and couldn't find a way to fix the Mode indicatator problem. I hope I'm wrong and someone will tell us we just missed it.